You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 22 Next »

Additional introduction to be added.

Table Of Contents

Introduction

More info coming soon...


Example image provided by Saul Espinosa can be downloaded below. 

Compositing_with_ACES_Example.zip

Contents:
  • ACEScg_OCIO_Example.exr - Primary example image to be used in ACEScg compositing workflow.
  • Output Example JPEGs - Example JPGs provided as both correct and incorrect output results to compare with your own results.


ACES in Photoshop


Step 1

OCIO Support for Photoshop is still less than ideal, for now the best way to use ACES in Photoshop is to first download and make use of the fnord plugin OpenColorIO for Photoshop.

Step 2

First open your ACEScg footage in Photoshop.

Step 3

Then convert your ACEScg layer to a smart object.

This is a very important step if you will be doing any editing. All adjustments must occur inside of the ACEScg smart object itself in order to properly make use of the ACES workflow.


Step 4

Then apply the OpenColorIO plugin as a smart filter to your ACEScg footage layer.

Step 5

Then set your OCIO config file path.

Set the mode to "Display"

Input Space: ACEScg

Display: sRGB (or your own monitor's display color space)

View: ACES 1.0 SDR-video (or the same View transform you were using in Redshift)

Step 6

Now the ACEScg footage is being previewed with the correct ODT but it still does not look correct in Photoshop, this is due to an extra gamma correction that Photoshop is applying.

Step 7

To counteract this gamma correction issue apply another OpenColorIO smart filter to the ACEScg footage, but this time with different settings.

Use the same configuration file used last time.

Set the mode to "Convert"

Input Space: sRGB

Output Space: scene-linear Rec.709-sRGB

Step 8

Now the ACEScg footage looks correct and is working properly with its two OpenColorIO transforms.


Reminder

The correct way to adjust ACEScg footage with the Photoshop workflow above is only possible inside the smart object itself as demonstrated in the video below.


ACES in After Effects


Step 1

OCIO Support for After Effects is still less than ideal, for now the best way to use ACES in After Effects is to first download and make use of the fnord plugin OpenColorIO for After Effects.

Step 2

First import your ACEScg footage into After Effects and place it in a new composition.

Step 3

Now set up your Project Settings. This can be found either by clicking the small button at the bottom of the Project panel circled in the image below or going to File > Project Settings.

Step 4

Under the Color tab set the following settings:

Depth: 32 bits per channel (float)

Working Space: sRGB IEC61966-2.1

Linearize Working Space: Enabled

Step 5

Next create a new adjustment layer above your ACEScg footage in the composition. We will name this adjustment layer and refer to it as "ACEScg to sRGB."

Step 6

Then add an OpenColorIO effect to the "ACEScg to sRGB" adjustment layer. This effect is found under Effects > Utility > OpenColorIO.

Step 7

Now set your OCIO config location for the OpenColorIO effect.

Step 8

Use the following settings:

Set the mode to "Convert"

Input Space: ACES - ACEScg

Output Space: Output - sRGB


Step 9

Now the ACEScg footage is being previewed with the correct ACES ODT but it still does not actually look correct in After Effects, this is due to an extra gamma correction that After Effects color management is applying.


Step 10

To counteract this gamma correction issue add a Color Profile Converter effect beneath the existing OpenColorIO effect, this can be found under Effects > Utility > Color Profile Converter.


Step 11

Use the following settings for the Color Profile Converter:

Input Profile: sRGB IEC61966-2.1

Output Profile: sRGB IEC61966-2.1

Linearize Output Profile: Enabled

Step 12

Now the ACEScg footage looks correct and will render out properly.


Reminder

The correct way to adjust ACEScg footage with this After Effects workflow should be done above your ACEScg footage but below the "ACEScg to sRGB" adjustment layer. This is demonstrated below with an Exposure effect being applied to an adjustment layer titled "Color Correction" in between the two layers. You want to apply any color corrections first to the ACEScg footage when still linear so it must be done in this order before the ODT conversion that converts your image to non-linear. This also means that you can composite multiple ACEScg openEXRs render layers all under the same one "ACEScg to sRGB" adjustment layer.

Correct color correction result and layer orderIncorrect color correction result and layer order



ACES in Nuke


Step 1

Navigate to the Color tab of your Nuke Project settings. 

Step 2

Set your "Color Management" to OCIO.

Step 3

Set the "OCIO config" to an ACES configuration or provide the path of your own custom OCIO config.

Step 4

Your Read nodes for ACES footage should already be set up with the correct color space of scene linear as pictured below.

Step 5

Set your Viewer to the correct output display transform that corresponds with the display you are using to view your work on.


ACES in Resolve

There are multiple ways to add an ACES transform to footage in Resolve, the most common methods are covered below.

ACES via Edit Page in Resolve


Step 1

Start by adding your ACES footage to a timeline and switching to the Edit page.

Step 2

Then add an ACES Transform effect to your footage found under the Open FX > Resolve FX Color section.

Step 3

Next switch to the Effects tab so you can access the ACES Transform options.

Step 4

Then set your ACES version, Input Transform to "CSC - ACEScg" and Output Transform to the color space corresponding to the monitor you are working on, in most cases sRGB.


Step 5

Now your footage is set up properly.

Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB.



Before ACES TransformAfter ACES Transform

ACES via Color Page in Resolve


Step 1

From the Color page start by adding an ACES Transform node to your color correction graph.


Step 2

Then set your ACES version, Input Transform to "CSC - ACEScg" and Output Transform to the color space corresponding to the monitor you are working on, in most cases sRGB.


Setting Input Transform to ACEScg


Setting Output Transform to sRGB

Step 3

Now your footage is set up properly.

Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB.



Before ACES TransformAfter ACES Transform


ACES in Fusion


Step 1

With your footage imported via a Loader create an OCIO Colorspace node downstream from your footage. This effect can be found under the Tools > Color section.

Step 2

First specify the location of your OCIO Config file.

Step 3

Then set your Source Space to "ACEScg" and Output Space to the color space corresponding to the monitor you are working on, in most cases sRGB.


Step 4

Now your footage is set up properly.

Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB.



Before ACES TransformAfter ACES Transform


ACES in Affinity Photo / Designer / Publisher


Step 1

Before you begin working you must first specify your OCIO config path by opening the Affinity Preferences > Color section.



Step 2

Then press the "Select..." button and navigate to and select your OCIO config file. A restart of the program may be required after this step.

Step 3

Next open your footage and add an Adjustment by clicking the button located at the bottom of the Layers panel circled below...

Step 4

...and select the OCIO adjustment.

Step 5

Then set your Source Color Space (IDT) to "ACEScg" and Destination Color Space (ODT) to the color space corresponding to the monitor you are working on, in most cases sRGB.

Step 6

Next add a Levels adjustment and apply a Gamma adjustment of 2. 

This step is necessary because Affinity applies a double gamma correction. Without this manual gamma adjustment your footage will export incorrectly and not match your view while working inside Affinity.


Step 7

Now your footage is set up properly.



Before ACES TransformAfter ACES Transform


ACES in Natron


Step 1

Start by bringing in your footage with a read node. A read node has built in OCIO support but should be left to ACEScg / raw for the input and output transforms so we can work in ACEScg and then transform to sRGB later.


Step 2

Then create an OCIO Colorspace node and set your OCIO config file. Set your Input Colorspace to ACEScg and your Output Colorspace to sRGB


Step 3

Now you can do your compositing work in ACEScg in between the Read and OCIO Colorspace nodes but we're still incorrectly previewing the footage with a double sRGB transform in the viewer so the preview color space should be set to Linear in order to display the footage properly.


Step 4

Make sure that when exporting your footage with a Write node you set the Input and File Colorspaces to linear / raw in order to avoid the double sRGB transform as well.