Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Reverted from v. 29
Info

Additional introduction to be added.

Table Of Contents

Table of Content Zone

Table of Contents
maxLevel2
excludeTable Of Contents

...

Info
Example image provided by Saul Espinosa can be downloaded below. 

Compositing_with_ACES_Example.zip

Contents:
  • ACEScg_OCIO_Example.exr - Primary example image to be used in ACEScg compositing workflow.
  • Output Example JPEGs - Example JPGs provided as both correct and incorrect output results to compare with your own results.


Panel

ACES in Photoshop

There are multiple ways to add an ACES transform to footage in Photoshop, the most common methods are covered below. 

ACES via fnord OpenColorIO Plugin for Photoshop

Expand
titleClick here for ACES via OCIO plugin in Photoshop workflow...

Step 1

OCIO Support for Photoshop is still less than ideal, for now the best way to use ACES in Photoshop is to first download and make use of the fnord plugin OpenColorIO for Photoshop.

Step 2

First open your ACEScg footage in Photoshop.

Step 3

Then convert your ACEScg layer to a smart object.

Warning

This is a very important step if you will be doing any editing. All adjustments mustoccur inside of the ACEScg smart object itself in order to properly make use of the ACES workflow.


Step 4

Then apply the OpenColorIO plugin as a smart filter to your ACEScg footage layer.

Step 5

Then set your OCIO config file path.

Set the mode to "Display"

Input Space: ACEScg

Display: sRGB (or your own monitor's display color space)

View: ACES 1.0 SDR-video (or the same View transform you were using in Redshift)

Step 6

Now the ACEScg footage is being previewed with the correct ODT but it still does not look correct in Photoshop, this is due to an extra gamma correction that Photoshop is applying.

Step 7

To counteract this gamma correction issue apply another OpenColorIO smart filter to the ACEScg footage, but this time with different settings.

Use the same configuration file used last time.

Set the mode to "Convert"

Input Space: sRGB

Output Space: scene-linear Rec.709-sRGB

Step 8

Now the ACEScg footage looks correct and is working properly with its two OpenColorIO transforms.


Info

Reminder

The correct way to adjust ACEScg footage with the Photoshop workflow above is only possible inside the smart object itself as demonstrated in the video below.

Multimedia
namePhotoshop_Correct_Adjustments.mp4
width600


ACES via a LUT in Photoshop

Expand
titleClick here for ACES via LUT in Photoshop workflow...


Warning
titleSimplicity vs Color Accuracy

Please note that using this method has the potential to result in slight color shifts in the final output, especially for highlights, that may not match what is seen in the Redshift Render View and other more compatible OCIO viewers so please only use this method with that understanding.

However, this LUT method is much more simple than the alternative Photoshop workflow outlined above and still maintains most of the benefits of an ACES pipeline.  

Image Added


Note
titleRequired Photoshop LUTs download

You will need the following LUTs in order to utilize this method. 


Photoshop_ACES_CSP_LUTs.zip credit Saul Espinosa

Step 1

First open your ACEScg footage in Photoshop.

Image Added

Step 2

Then, from the Layers panel, create a new Adjustment Layer > Color Lookup

Image Added

Step 3

Next you must load the appropriate LUT from the Color Lookup's Properties panel seen below. 

Click on the "Load 3D LUT" drop down and then click on the "Load 3D LUT..." text to bring up a file open dialog. 

Image Added

Step 4

Navigate to where you saved the downloaded LUT files and load the appropriate LUT for your project, you may need to select the CSP file type in order to be able to see and select the LUTs.

Note
titleDefault Settings LUT

For this OCIO demonstration and any Redshift project that uses the default OCIO ACES settings you should use the ACEScg_Photoshop_to_sRGB_ACES_1.0_SDR-Video.csp LUT file. 

Step 5

Now the ACEScg footage looks good and is working as expected with the properly setup Color Lookup Adjustment Layer.

Image Added


Info

Reminder

The correct way to adjust ACEScg footage with this Photoshop workflow is above your ACEScg footage but below the Color Lookup adjustment layer. This is demonstrated below with an Exposure effect being applied to an adjustment layer titled "Color Correction" in between the two layers. The reason for this is that you want to apply any color corrections to the ACEScg footage when it is still linear so it must be done before the ODT conversion that converts your image to non-linear via the Color Lookup. This also means that you can composite multiple ACEScg openEXRs render layers all under the same one Color Lookup adjustment layer.

Rs divbox
classrs-img-table 2


Image Added

Image Added

Correct color correction result and layer orderIncorrect color correction result and layer order







Panel

ACES in After Effects


Expand
titleClick here for ACES in After Effects walkthrough...

Step 1

OCIO Support for After Effects is still less than ideal, for now the best way to use ACES in After Effects is to first download and make use of the fnord plugin OpenColorIO for After Effects.


Note
titlefnord OCIO Plugin Version

Make sure you have fnord OCIO version 2.1.1 or later which was released in December 2021 for OCIO v2 support in order to be able to use the same OCIO config file that ships with Redshift.


Step 2

First import your ACEScg footage into After Effects and place it in a new composition.

Step 3

Now set up your Project Settings. This can be found either by clicking the small button at the bottom of the Project panel circled in the image below or going to File > Project Settings.

Step 4

Under the Color tab set the following settings:

Depth: 32 bits per channel (float)

Working Space: sRGB IEC61966-2.1

Linearize Working Space: Enabled

Step 5

Next create a new adjustment layer above your ACEScg footage in the composition. We will name this adjustment layer and refer to it as "ACEScg to sRGB."

Step 6

Then add an OpenColorIO effect to the "ACEScg to sRGB" adjustment layer. This effect is found under Effects > Utility > OpenColorIO.

Step 7

Now set your OCIO config location for the OpenColorIO effect.

Step 8

Use the following settings:

Set the mode to "Display"

Input Space: ACEScg

Output Space: sRGB 

View: ACES 1.0 SDR-video 


Step 9

Now the ACEScg footage is being previewed with the correct ACES ODT but it still does not actually look correct in After Effects, this is due to an extra gamma correction that After Effects color management is applying.


Step 10

To counteract this gamma correction issue add a Color Profile Converter effect beneath the existing OpenColorIO effect, this can be found under Effects > Utility > Color Profile Converter.


Step 11

Use the following settings for the Color Profile Converter:

Input Profile: sRGB IEC61966-2.1

Output Profile: sRGB IEC61966-2.1

Linearize Output Profile: Enabled

Step 12

Now the ACEScg footage looks correct and will render out properly.


Info

Reminder

The correct way to adjust ACEScg footage with this After Effects workflow should be done is above your ACEScg footage but below the "ACEScg to sRGB" adjustment layer. This is demonstrated below with an Exposure effect being applied to an adjustment layer titled "Color Correction" in between the two layers. You want to apply any color corrections first to the ACEScg footage when still linear so it must be done in this order before the ODT conversion that converts your image to non-linear. This also means that you can composite multiple ACEScg openEXRs render layers all under the same one "ACEScg to sRGB" adjustment layer.

Rs divbox
classrs-img-table 2


Correct color correction result and layer orderIncorrect color correction result and layer order






...

Panel

ACES in Nuke


Expand
titleClick here for Nuke walkthrough...

Step 1

Navigate to the Color tab of your Nuke Project settings. 

Step 2

Set your "Color Management" to OCIO.

Step 3

Set the "OCIO config" to an ACES configuration or provide the path of your own custom OCIO config.

Step 4

Your Read nodes for ACES footage should already be set up with the correct color space of scene linear as pictured below.

Step 5

Set your Viewer to the correct output display transform that corresponds with the display you are using to view your work on.


...

Panel

ACES in Resolve

There are multiple ways to add an ACES transform to footage in Resolve, the most common methods are covered below.

ACES via Project Settings in Resolve

Expand
titleClick here for ACES via Project Settings in Resolve walkthrough...

Step 1

To make the results of your settings changes more apparent start by adding your ACES footage to a timeline..

Step 2

Then open your "Project Settings" which is found in the File menu.

Step 3

Next select the "Color Management" section on the left side of the Project Settings panel and then change your "Color science" to ACEScc or ACEScct.

Step 4

Then set your ACES version, Input Device Transform to "CSC - ACEScg" and Output Device Transform to the color space corresponding to the monitor you are working on, in most cases sRGB.


Step 5

Now your ACES footage is set up properly.


Rs divbox
classrs-img-table2


Default Resolve Color science (without ACES Transform)ACES Color science (with ACES Transform)



ACES via Edit Page in Resolve


Expand
titleClick here for ACES via Edit Page in Resolve walkthrough...

Step 1

Start by adding your ACES footage to a timeline and switching to the Edit page.

Step 2

Then add an ACES Transform effect to your footage found under the Open FX > Resolve FX Color section.

Step 3

Next switch to the Effects tab so you can access the ACES Transform options.

Step 4

Then set your ACES version, Input Transform to "CSC - ACEScg" and Output Transform to the color space corresponding to the monitor you are working on, in most cases sRGB.

Rs divbox
classrs-img-table2




Step 5

Now your footage is set up properly.

Info

Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB.


Rs divbox
classrs-img-table2



Before ACES TransformAfter ACES Transform



ACES via Color Page in Resolve


Expand
titleClick here for ACES via Color Page in Resolve walkthrough...

Step 1

From the Color page start by adding an ACES Transform node to your color correction graph.


Step 2

Then set your ACES version, Input Transform to "CSC - ACEScg" and Output Transform to the color space corresponding to the monitor you are working on, in most cases sRGB.

Rs divbox
classrs-img-table2



Setting Input Transform to ACEScg


Setting Output Transform to sRGB


Step 3

Now your footage is set up properly.

Info

Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB.


Rs divbox
classrs-img-table2



Before ACES TransformAfter ACES Transform




...

Panel

ACES in Fusion


Expand
titleClick here for ACES in Fusion walkthrough...

Step 1

With your footage imported via a Loader create an OCIO Colorspace node downstream from your footage. This effect can be found under the Tools > Color section.

Step 2

First specify the location of your OCIO Config file.

Step 3

Then set your Source Space to "ACEScg" and Output Space to the color space corresponding to the monitor you are working on, in most cases sRGB.

Rs divbox
classrs-img-table2




Step 4

Now your footage is set up properly.

Info

Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB.


Rs divbox
classrs-img-table2



Before ACES TransformAfter ACES Transform




...

Panel

ACES in Affinity Photo / Designer / Publisher


Expand
titleClick here for ACES in Affinity walkthrough...

Step 1

Before you begin working you must first specify your OCIO config path by opening the Affinity Preferences > Color section.

Rs divbox
classrs-img-table2





Step 2

Then press the "Select..." button and navigate to and select your OCIO config file. A restart of the program may be required after this step.

Step 3

Next open your footage and add an Adjustment by clicking the button located at the bottom of the Layers panel circled below...

Step 4

...and select the OCIO adjustment.

Step 5

Then set your Source Color Space (IDT) to "ACEScg" and Destination Color Space (ODT) to the color space corresponding to the monitor you are working on, in most cases sRGB.

Step 6

Next add a Levels adjustment and apply a Gamma adjustment of 2. 

Image RemovedImage Added

Warning

This step is necessary because Affinity applies a double gamma correction. Without this manual gamma adjustment your footage will export incorrectly and not match your view while working inside Affinity.


Step 7

Now your footage is set up properly.


Rs divbox
classrs-img-table2



Before ACES TransformAfter ACES Transform




...

Panel

ACES in Natron


Expand
titleClick here for ACES in Natron workflow...

Step 1

Start by bringing in your footage with a read node. A read node has built in OCIO support but should be left to ACEScg / raw for the input and output transforms so we can work in ACEScg and then transform to sRGB later.


Info

Effectively Natron's read node has the ACES IDT built right in, alternatively you could also use an OCIO colorspace node with the same settings for the same result.



Step 2

Then create an OCIO Colorspace node (this will function as our ACES ODT) and set your OCIO config file. Set your Input Colorspace to ACEScg and your Output Colorspace to sRGB. This color transform should take place before writing out / rendering your footage so the ACES ODT is baked in.

Warning

The node graph is now setup properly but by using Natron's default viewer settings we're still incorrectly previewing the footage in the viewer due to an extra sRGB transform being applied and making it far too bright as seen in the example image below. The solution to this is covered in the next step.



Step 3

To remove the unwanted sRGB transform make certain to set your viewer lut to "Linear (None)" as highlighted in the image below to preview your footage correctly.

With this change now your footage looks correct in the viewer and you can do your compositing work in ACEScg as long as the editing takes place before the ACES ODT.


Step 4

Make sure that when exporting your footage with a Write node that you set the Input and File Colorspaces to linear / raw in order to avoid the double sRGB transform as well.

The ACES ODT is already coverting the footage to the appropriate sRGB output.


...